How to Install and Uninstall librust-ashpd-dev Package on Ubuntu 24.04 LTS (Noble Numbat)

Last updated: June 16,2024

1. Install "librust-ashpd-dev" package

Please follow the step by step instructions below to install librust-ashpd-dev on Ubuntu 24.04 LTS (Noble Numbat)

$ sudo apt update $ sudo apt install librust-ashpd-dev

2. Uninstall "librust-ashpd-dev" package

This tutorial shows how to uninstall librust-ashpd-dev on Ubuntu 24.04 LTS (Noble Numbat):

$ sudo apt remove librust-ashpd-dev $ sudo apt autoclean && sudo apt autoremove

3. Information about the librust-ashpd-dev package on Ubuntu 24.04 LTS (Noble Numbat)

Package: librust-ashpd-dev
Architecture: amd64
Version: 0.6.7-1
Multi-Arch: same
Priority: optional
Section: universe/rust
Source: rust-ashpd
Origin: Ubuntu
Maintainer: Ubuntu Developers
Original-Maintainer: Debian Rust Maintainers
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 412
Provides: librust-ashpd+async-std-dev (= 0.6.7-1), librust-ashpd+default-dev (= 0.6.7-1), librust-ashpd+gdk4wayland-dev (= 0.6.7-1), librust-ashpd+gdk4x11-dev (= 0.6.7-1), librust-ashpd+gtk4-dev (= 0.6.7-1), librust-ashpd+gtk4-wayland-dev (= 0.6.7-1), librust-ashpd+gtk4-x11-dev (= 0.6.7-1), librust-ashpd+libc-dev (= 0.6.7-1), librust-ashpd+pipewire-dev (= 0.6.7-1), librust-ashpd+pw-dev (= 0.6.7-1), librust-ashpd+raw-handle-dev (= 0.6.7-1), librust-ashpd+raw-window-handle-dev (= 0.6.7-1), librust-ashpd+tokio-dev (= 0.6.7-1), librust-ashpd+tracing-dev (= 0.6.7-1), librust-ashpd+wayland-backend-dev (= 0.6.7-1), librust-ashpd+wayland-client-dev (= 0.6.7-1), librust-ashpd+wayland-dev (= 0.6.7-1), librust-ashpd+wayland-protocols-dev (= 0.6.7-1), librust-ashpd-0+async-std-dev (= 0.6.7-1), librust-ashpd-0+default-dev (= 0.6.7-1), librust-ashpd-0+gdk4wayland-dev (= 0.6.7-1), librust-ashpd-0+gdk4x11-dev (= 0.6.7-1), librust-ashpd-0+gtk4-dev (= 0.6.7-1), librust-ashpd-0+gtk4-wayland-dev (= 0.6.7-1), librust-ashpd-0+gtk4-x11-dev (= 0.6.7-1), librust-ashpd-0+libc-dev (= 0.6.7-1), librust-ashpd-0+pipewire-dev (= 0.6.7-1), librust-ashpd-0+pw-dev (= 0.6.7-1), librust-ashpd-0+raw-handle-dev (= 0.6.7-1), librust-ashpd-0+raw-window-handle-dev (= 0.6.7-1), librust-ashpd-0+tokio-dev (= 0.6.7-1), librust-ashpd-0+tracing-dev (= 0.6.7-1), librust-ashpd-0+wayland-backend-dev (= 0.6.7-1), librust-ashpd-0+wayland-client-dev (= 0.6.7-1), librust-ashpd-0+wayland-dev (= 0.6.7-1), librust-ashpd-0+wayland-protocols-dev (= 0.6.7-1), librust-ashpd-0-dev (= 0.6.7-1), librust-ashpd-0.6+async-std-dev (= 0.6.7-1), librust-ashpd-0.6+default-dev (= 0.6.7-1), librust-ashpd-0.6+gdk4wayland-dev (= 0.6.7-1), librust-ashpd-0.6+gdk4x11-dev (= 0.6.7-1), librust-ashpd-0.6+gtk4-dev (= 0.6.7-1), librust-ashpd-0.6+gtk4-wayland-dev (= 0.6.7-1), librust-ashpd-0.6+gtk4-x11-dev (= 0.6.7-1), librust-ashpd-0.6+libc-dev (= 0.6.7-1), librust-ashpd-0.6+pipewire-dev (= 0.6.7-1), librust-ashpd-0.6+pw-dev (= 0.6.7-1), librust-ashpd-0.6+raw-handle-dev (= 0.6.7-1), librust-ashpd-0.6+raw-window-handle-dev (= 0.6.7-1), librust-ashpd-0.6+tokio-dev (= 0.6.7-1), librust-ashpd-0.6+tracing-dev (= 0.6.7-1), librust-ashpd-0.6+wayland-backend-dev (= 0.6.7-1), librust-ashpd-0.6+wayland-client-dev (= 0.6.7-1), librust-ashpd-0.6+wayland-dev (= 0.6.7-1), librust-ashpd-0.6+wayland-protocols-dev (= 0.6.7-1), librust-ashpd-0.6-dev (= 0.6.7-1), librust-ashpd-0.6.7+async-std-dev (= 0.6.7-1), librust-ashpd-0.6.7+default-dev (= 0.6.7-1), librust-ashpd-0.6.7+gdk4wayland-dev (= 0.6.7-1), librust-ashpd-0.6.7+gdk4x11-dev (= 0.6.7-1), librust-ashpd-0.6.7+gtk4-dev (= 0.6.7-1), librust-ashpd-0.6.7+gtk4-wayland-dev (= 0.6.7-1), librust-ashpd-0.6.7+gtk4-x11-dev (= 0.6.7-1), librust-ashpd-0.6.7+libc-dev (= 0.6.7-1), librust-ashpd-0.6.7+pipewire-dev (= 0.6.7-1), librust-ashpd-0.6.7+pw-dev (= 0.6.7-1), librust-ashpd-0.6.7+raw-handle-dev (= 0.6.7-1), librust-ashpd-0.6.7+raw-window-handle-dev (= 0.6.7-1), librust-ashpd-0.6.7+tokio-dev (= 0.6.7-1), librust-ashpd-0.6.7+tracing-dev (= 0.6.7-1), librust-ashpd-0.6.7+wayland-backend-dev (= 0.6.7-1), librust-ashpd-0.6.7+wayland-client-dev (= 0.6.7-1), librust-ashpd-0.6.7+wayland-dev (= 0.6.7-1), librust-ashpd-0.6.7+wayland-protocols-dev (= 0.6.7-1), librust-ashpd-0.6.7-dev (= 0.6.7-1)
Depends: librust-async-std-1+default-dev (>= 1.12-~~), librust-enumflags2-0.7+default-dev, librust-futures-channel-0.3+default-dev, librust-futures-util-0.3+default-dev, librust-gdk4-wayland-0.7+default-dev, librust-gdk4-x11-0.7+default-dev, librust-gtk4-0.7+default-dev, librust-libc-0.2+default-dev, librust-once-cell-1+default-dev (>= 1.14-~~), librust-pipewire-0.7+default-dev, librust-rand-0.8-dev, librust-raw-window-handle-0.5+default-dev, librust-serde-1+default-dev, librust-serde-1+derive-dev, librust-serde-repr-0.1+default-dev, librust-tokio-1+fs-dev (>= 1.21-~~), librust-tokio-1+io-util-dev (>= 1.21-~~), librust-tracing-0.1+default-dev, librust-url-2+default-dev (>= 2.3-~~), librust-url-2+serde-dev (>= 2.3-~~), librust-wayland-backend-0.1+client-system-dev, librust-wayland-backend-0.1+default-dev, librust-wayland-client-0.30+default-dev, librust-wayland-protocols-0.30+client-dev, librust-wayland-protocols-0.30+default-dev, librust-wayland-protocols-0.30+unstable-dev, librust-zbus-3+async-io-dev (>= 3.1-~~), librust-zbus-3+tokio-dev (>= 3.1-~~), librust-zbus-3+url-dev (>= 3.1-~~)
Filename: pool/universe/r/rust-ashpd/librust-ashpd-dev_0.6.7-1_amd64.deb
Size: 63232
MD5sum: e5eec322de49c8a102da47d0912301c9
SHA1: 67fb7d2f6e9ed7d12b84a0a967dbb43b40ff3560
SHA256: d71820e4a987557803cc6f2c365d12ed7d0f2018be9cb27d10b149c8bc6e4cda
SHA512: 1fb82bf4b3c1daab4dfcb5d9b81dafd81cfee0e5d6243f143deb3c6fb3546818e30fe5c27ad3fd715ba23ef5942986f6de55139bbf9c5d6dd68edc1323413d1c
Description: XDG portals wrapper in Rust using zbus - Rust source code
Description-md5: 4e01c22b9abbb36d9752d3320739362b