Linux Packages

2to3 package on Ubuntu 18.04 LTS (Bionic Beaver)

Current version: 3.6.7-1~18.04

How to install or uninstall 2to3 on Ubuntu 18.04 LTS (Bionic Beaver)?

Last updated on January 20, 2022

1. Install 2to3 package.

Please follow the instructions below to install 2to3 package:

sudo apt update
sudo apt install 2to3

2. Uninstall / Remove 2to3 package.

Please follow the instructions below to uninstall 2to3 package:

sudo apt remove 2to3
sudo apt autoclean && sudo apt autoremove

3. Full information of 2to3 package.

Package: 2to3
Architecture: all
Version: 3.6.7-1~18.04
Multi-Arch: foreign
Priority: optional
Section: universe/python
Source: python3-defaults
Origin: Ubuntu
Maintainer: Ubuntu Developers
Original-Maintainer: Matthias Klose
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 42
Depends: python3-lib2to3 (>= 3.6.7-1~), python3 (>= 3.6.7-1~18.04)
Breaks: python (<< 2.7.14-4)
Replaces: python (<< 2.7.14-4)
Filename: pool/universe/p/python3-defaults/2to3_3.6.7-1~18.04_all.deb
Size: 8044
MD5sum: 4c55e30e5444b6ec3454c634831d60c3
SHA1: bd2574dffe48b71fcc5c0d7b4a580860c587f587
SHA256: 2f43b4fc8745cfabbcbe312752a5499b2432b6f2bd4f0074328a64e214b57e79
SHA512: 989dfb23b2f027ba4a443776601221fb3463688a8e2e917a3e981561641e613f868f284f06575a8bd22cfbb6734b8095b525f4df07f8b2739218f1396d6da92f
Homepage: https://www.python.org/
Description-en: 2to3 binary using python3
Python, the high-level, interactive object oriented language,
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.
.
This package is a dependency package, which depends on Debian's default
Python 3 2to3 version (currently v3.6).
Description-md5: f8d1571da456d6c8d5e1a0140cc92b40

Package: 2to3
Architecture: all
Version: 3.6.5-3
Multi-Arch: foreign
Priority: optional
Section: universe/python
Source: python3-defaults
Origin: Ubuntu
Maintainer: Ubuntu Developers
Original-Maintainer: Matthias Klose
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 42
Depends: python3-lib2to3 (>= 3.6.5-2~), python3 (>= 3.6.5-3)
Breaks: python (<< 2.7.14-4)
Replaces: python (<< 2.7.14-4)
Filename: pool/universe/p/python3-defaults/2to3_3.6.5-3_all.deb
Size: 8080
MD5sum: 01896a3eb72e022fad91b4be3692ce4d
SHA1: a1aaaa18c2e23aa9aceea1008872f8a58f37672e
SHA256: b353abce6a969f534a1c01af3bc48446f105a73848f86d46f490333f35c6a6ff
Homepage: http://www.python.org/
Description-en: 2to3 binary using python3
Python, the high-level, interactive object oriented language,
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.
.
This package is a dependency package, which depends on Debian's default
Python 3 2to3 version (currently v3.6).
Description-md5: f8d1571da456d6c8d5e1a0140cc92b40

4. Related packages on Ubuntu 18.04 LTS (Bionic Beaver).