How to Install and Uninstall puppet-lint Package on Ubuntu 20.04 LTS (Focal Fossa)

Last updated: June 16,2024

1. Install "puppet-lint" package

This guide let you learn how to install puppet-lint on Ubuntu 20.04 LTS (Focal Fossa)

$ sudo apt update $ sudo apt install puppet-lint

2. Uninstall "puppet-lint" package

Please follow the steps below to uninstall puppet-lint on Ubuntu 20.04 LTS (Focal Fossa):

$ sudo apt remove puppet-lint $ sudo apt autoclean && sudo apt autoremove

3. Information about the puppet-lint package on Ubuntu 20.04 LTS (Focal Fossa)

Package: puppet-lint
Architecture: all
Version: 2.4.2-2
Priority: optional
Section: universe/ruby
Origin: Ubuntu
Maintainer: Ubuntu Developers
Original-Maintainer: Puppet Package Maintainers
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 194
Depends: ruby | ruby-interpreter
Suggests: rake
Filename: pool/universe/p/puppet-lint/puppet-lint_2.4.2-2_all.deb
Size: 38864
MD5sum: 6d22328d4c729287587736f751ed7bc9
SHA1: 8c6abe380f7e31f74e998a7f66a5b1af1a38d3b4
SHA256: f216ff7bed64ed47d61075de26672182f5d42e43955d3e3f6b80442c1bf05b2d
Homepage: https://github.com/rodjek/puppet-lint/
Description: check puppet manifests for style guide conformity
Description-md5: 85b28c37ea18f31e6ea1e2fa6070d9b3
Ruby-Versions: all