php-solr on Ubuntu 20.04 LTS (Focal Fossa)

Last updated: December 03,2022

1. Install php-solr package

Please follow the guidelines below to install php-solr package:

sudo apt update
sudo apt install php-solr

2. Uninstall / Remove php-solr package

This tutorial shows how to uninstall php-solr package:

sudo apt remove php-solr
sudo apt autoclean && sudo apt autoremove

3. Details of php-solr package

Package: php-solr
Priority: optional
Section: php
Installed-Size: 15
Maintainer: Debian PHP PECL Maintainers
Architecture: amd64
Version: 2.5.1+2.4.0-10+ubuntu20.04.1+deb.sury.org+3
Depends: php8.1-solr, php-curl, php-xml
Pre-Depends: php-common (>= 2:69~)
Filename: pool/main/p/php-solr/php-solr_2.5.1+2.4.0-10+ubuntu20.04.1+deb.sury.org+3_amd64.deb
Size: 5904
MD5sum: e863a4369f0ea494517e818eeb8790e3
SHA1: 48b8b3469a70ffe0d902a884b54203f14a694cdc
SHA256: 57bacad0b3946048da5a24b7f6345db0a1f7a49ac518e66b7cbd711889ba5ad9
Description: PHP extension for communicating with Apache Solr server
Description-md5: d404cb885f81e4bef1b57c8bb1c01e9b

Package: php-solr
Architecture: amd64
Version: 2.5.0+2.4.0-4build1
Priority: optional
Section: universe/web
Origin: Ubuntu
Maintainer: Ubuntu Developers
Original-Maintainer: Debian PHP PECL Maintainers
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 352
Provides: php7.4-solr
Pre-Depends: php-common (>= 2:69~)
Depends: php-curl, phpapi-20190902, libc6 (>= 2.14), libcurl4 (>= 7.16.2), libxml2 (>= 2.7.4)
Filename: pool/universe/p/php-solr/php-solr_2.5.0+2.4.0-4build1_amd64.deb
Size: 84836
MD5sum: 81e88d9e08a72f5ed2300974c8d577ab
SHA1: ffca53cc1e502aa9729a9d63eda34cf47606cdc0
SHA256: aa8d1377881804c12073be84577752211209bcb3ae914f70554137194c66eaca
Homepage: http://pecl.php.net/package/solr
Description: PHP extension for communicating with Apache Solr server
Description-md5: d404cb885f81e4bef1b57c8bb1c01e9b