How to Install and Uninstall php-ssh2-all-dev Package on Ubuntu 20.04 LTS (Focal Fossa)

Last updated: February 26,2024

1. Install "php-ssh2-all-dev" package

Please follow the instructions below to install php-ssh2-all-dev package:

$ sudo apt update $ sudo apt install php-ssh2-all-dev

2. Uninstall "php-ssh2-all-dev" package

This guide let you learn how to uninstall php-ssh2-all-dev package:

$ sudo apt remove php-ssh2-all-dev $ sudo apt autoclean && sudo apt autoremove

3. Information about the php-ssh2-all-dev package

Package: php-ssh2-all-dev
Source: php-ssh2
Priority: extra
Section: php
Installed-Size: 13
Maintainer: Debian PHP PECL Maintainers
Architecture: all
Version: 1.4-1+ubuntu20.04.1+deb.sury.org+2
Replaces: libssh2-php (<< 0.12-2)
Depends: php8.3-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php8.2-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php8.1-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php8.0-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php7.4-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php7.3-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php7.2-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php7.1-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php7.0-ssh2 (>= 1.4-1+ubuntu20.04.1+deb.sury.org+2~), php-all-dev
Pre-Depends: php-common (>= 2:69~)
Breaks: libssh2-php (<< 0.12-2)
Filename: pool/main/p/php-ssh2/php-ssh2-all-dev_1.4-1+ubuntu20.04.1+deb.sury.org+2_all.deb
Size: 5360
MD5sum: 06bd2990afba7fd62d67da27141ff5f7
SHA1: dc6ffe608641f1b28acdf1589a4624307324c953
SHA256: 2b4ac58e664dcd6918fe268edb604be960a2d7a8badc908c9503476f34d0ee37
Description: Bindings for the libssh2 library
Description-md5: 8adc0199b55f9ddf168edba900604566