How to Install and Uninstall libfastrtps2.5 Package on Linux Mint 21 (Vanessa)

Last updated: February 26,2024

1. Install "libfastrtps2.5" package

This tutorial shows how to install libfastrtps2.5 package:

$ sudo apt update $ sudo apt install libfastrtps2.5

2. Uninstall "libfastrtps2.5" package

This guide let you learn how to uninstall libfastrtps2.5 package:

$ sudo apt remove libfastrtps2.5 $ sudo apt autoclean && sudo apt autoremove

3. Information about the libfastrtps2.5 package

Package: libfastrtps2.5
Architecture: amd64
Version: 2.5.0+ds-3
Multi-Arch: same
Priority: optional
Section: universe/libs
Source: fastdds
Origin: Ubuntu
Maintainer: Ubuntu Developers
Original-Maintainer: Debian Robotics Team
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 7545
Depends: libc6 (>= 2.34), libfastcdr1 (>= 1.0.16), libfoonathan-memory0.7.1 (>= 0.7.1), libgcc-s1 (>= 3.0), libsqlite3-0 (>= 3.20.0), libssl3 (>= 3.0.0~~alpha1), libstdc++6 (>= 11), libtinyxml2-9 (>= 8.0.0)
Filename: pool/universe/f/fastdds/libfastrtps2.5_2.5.0+ds-3_amd64.deb
Size: 2138352
MD5sum: fd61d53c5551c3c3049d337c5431c379
SHA1: 5d7b42ee68a6fc7ea28268f740b5e394f3dfa276
SHA256: 5e88acf9fc211ed18f5d87274d60539058ab278e249dfe5b60d412a675a4ac45
SHA512: 6bf3be0f314c4b5904b6980f02602a9a44d2eee0e9abe53b62edcc9b69535a93bb5dc5d2fc2c2a62c015fe9294a70014962c3187f4757c11b8dc0e2044a1834b
Homepage: https://github.com/eProsima/Fast-DDS
Description: C++ library for the Real Time Publish Subscribe protocol
Description-md5: af2eed0518831ff042944686eeebca31