Linux Packages

libgcc-s1 package on Ubuntu 21.04 (Hirsute Hippo)

Current version: 11.1.0-1ubuntu1~21.04

How to install or uninstall libgcc-s1 on Ubuntu 21.04 (Hirsute Hippo)?

Last updated on January 20, 2022

1. Install libgcc-s1 package.

This guide let you learn how to install libgcc-s1 package:

sudo apt update
sudo apt install libgcc-s1

2. Uninstall / Remove libgcc-s1 package.

Please follow the guidance below to uninstall libgcc-s1 package:

sudo apt remove libgcc-s1
sudo apt autoclean && sudo apt autoremove

3. Full information of libgcc-s1 package.

Package: libgcc-s1
Architecture: amd64
Version: 11.1.0-1ubuntu1~21.04
Multi-Arch: same
Priority: required
Section: libs
Source: gcc-11
Origin: Ubuntu
Maintainer: Ubuntu Core developers
Original-Maintainer: Debian GCC Maintainers
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 120
Provides: libgcc1 (= 1:11.1.0-1ubuntu1~21.04)
Depends: gcc-11-base (= 11.1.0-1ubuntu1~21.04), libc6 (>= 2.14)
Replaces: libgcc1 (<< 1:10)
Filename: pool/main/g/gcc-11/libgcc-s1_11.1.0-1ubuntu1~21.04_amd64.deb
Size: 42180
MD5sum: bbd8c07c5dcd2b6a44cc2a0d7a9144b2
SHA1: 6458bf12d5a78a8a80ba65a8ce410caec46d625d
SHA256: d1d36605241b1fbdf6734c6d658d9550ba828009cfeb29254cba4a32261c6e4c
SHA512: 201ac8923e655cc9634785c9aec8be2bb9b4ffc90b8ebedc7381d167e533fd65a347a06b2d47eb41516804c92aecf2747f179d69c8e7d5ca5c1260b981db435d
Homepage: http://gcc.gnu.org/
Description-en: GCC support library
Shared version of the support library, a library of internal subroutines
that GCC uses to overcome shortcomings of particular machines, or
special needs for some languages.
Description-md5: bbd60d723e97d8e06c04228ee4c76f10
Task: minimal
Protected: yes
Important: yes

Package: libgcc-s1
Architecture: amd64
Version: 11-20210417-1ubuntu1
Multi-Arch: same
Priority: required
Section: libs
Source: gcc-11
Origin: Ubuntu
Maintainer: Ubuntu Core developers
Original-Maintainer: Debian GCC Maintainers
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 120
Provides: libgcc1 (= 1:11-20210417-1ubuntu1)
Depends: gcc-11-base (= 11-20210417-1ubuntu1), libc6 (>= 2.14)
Replaces: libgcc1 (<< 1:10)
Filename: pool/main/g/gcc-11/libgcc-s1_11-20210417-1ubuntu1_amd64.deb
Size: 42120
MD5sum: 40623fa959182d4a82b51cfdcc0929e4
SHA1: 145afef978ba1478c680503e8ba53091551eeb48
SHA256: 71b6850bc4bc7c3f9cfeab515efff265292e96c9b20ac53fa31bd93c6551069f
SHA512: 8515d7d151c0acaf1599aa6272a6373de48e425ec411f417db0d1c173b3848dded7725de8c73133e06c610848db828216b2fc315ff408f9e0a17884401b843d5
Homepage: http://gcc.gnu.org/
Description-en: GCC support library
Shared version of the support library, a library of internal subroutines
that GCC uses to overcome shortcomings of particular machines, or
special needs for some languages.
Description-md5: bbd60d723e97d8e06c04228ee4c76f10
Task: minimal
Protected: yes
Important: yes

4. Related packages on Ubuntu 21.04 (Hirsute Hippo).